注册 登录
  • 欢迎访问开心洋葱网站,在线教程,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站,欢迎加入开心洋葱 QQ群
  • 为方便开心用户,开心洋葱官网已经开启复制功能!
  • 欢迎访问开心洋葱网站,手机也能访问哦~欢迎加入开心洋葱多维思维学习平台 QQ群
  • 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏开心洋葱吧~~~~~~~~~~~~~!
  • 由于近期流量激增,小站的ECS没能经的起亲们的访问,本站依然没有盈利,如果各位看如果觉着文字不错,还请看官给小站打个赏~~~~~~~~~~~~~!

windows中文系统在安装metasploit的数据库postgresql会报错误,这是由于postgresql对中文支持问题导致。

windows 开心洋葱 2691次浏览 已收录 0个评论 手机上查看

windows中文系统在安装metasploit的数据库postgresql会报错误,这是由于postgresql对中文支持问题导致。

when i was installing the metasploit framework 3.5 on XP, I come across
with the following error message again and again.

There has been an error.
Unknown error while running C:\framework/postgresql/bin/psql.exe -U
postgres -p 8448 -h localhost -c “ALTER USER postgresql PASSWORD '********'”
The application will exit now.

I tried on two different xp, but got the same result. Would you please give
me a clue to solve this problem?

BTW, I once install the postgresql by myself, but now it has been removed.

 

windows中文系统在安装metasploit的数据库postgresql会报错误,这是由于postgresql对中文支持问题导致。

解决方法:控制面板-区域和语言选项-将标准与格式,改为英语(美国),在安装即可

或可以安装metasploit framework的mini版,该版本不安装postgresql自然也无上述错误了。但无法使用GUI界面和一些相关功能


On 11/29/2010 11:21 PM, Yuping Li wrote: hi, guyswhen i was installing the metasploit framework 3.5 on XP, I come across with the following error message again and again.There has been an error. Unknown error while running C:\framework/postgresql/bin/psql.exe -U postgres -p 8448 -h localhost -c “ALTER USER postgresql PASSWORD ‘****'” The application will exit now. We have seen this on some non-english versions of the install – the cause is the default locale in PostgreSQL is not compatible with the SQL_ASCII statements. We need to override the installation locale of PostgreSQL to resolve this and have an open ticket to resolve it.-HD
 


开心洋葱 , 版权所有丨如未注明 , 均为原创丨未经授权请勿修改 , 转载请注明windows中文系统在安装metasploit的数据库postgresql会报错误,这是由于postgresql对中文支持问题导致。
喜欢 (0)
[开心洋葱]
分享 (0)
关于作者:
开心洋葱,开心洋葱头,水墨

您必须 登录 才能发表评论!

……
加载中……