注册 登录
  • 欢迎访问开心洋葱网站,在线教程,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站,欢迎加入开心洋葱 QQ群
  • 为方便开心用户,开心洋葱官网已经开启复制功能!
  • 欢迎访问开心洋葱网站,手机也能访问哦~欢迎加入开心洋葱多维思维学习平台 QQ群
  • 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏开心洋葱吧~~~~~~~~~~~~~!
  • 由于近期流量激增,小站的ECS没能经的起亲们的访问,本站依然没有盈利,如果各位看如果觉着文字不错,还请看官给小站打个赏~~~~~~~~~~~~~!

Binary has a problem: Error: dlopen

PHP 开心洋葱 4045次浏览 已收录 0个评论 手机上查看

(node:23771) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.

> node-sass@3.13.1 install /yt/www/laravel-angular-admin/node_modules/node-sass
> node scripts/install.js

node-sass build Binary found at /yt/www/laravel-angular-admin/node_modules/[email protected]node-sass/vendor/darwin-x64-48/binding.node

> node-sass@3.13.1 postinstall /yt/www/laravel-angular-admin/node_modules/node-sass
> node scripts/build.js

Binary found at /yt/www/laravel-angular-admin/node_modules/[email protected]/vendor/darwin-x64-48/binding.node
Testing binary
Binary has a problem: Error: dlopen(/yt/www/laravel-angular-admin/node_modules/[email protected]/vendor/darwin-x64-48/binding.node, 1): no suitable image found. Did find:
/yt/www/laravel-angular-admin/node_modules/[email protected]/vendor/darwin-x64-48/binding.node: truncated mach-o error: segment __TEXT extends to 1212416 which is past end of file 86576
at Error (native)
at Object.Module._extensions..node (module.js:597:18)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at module.exports (/yt/www/laravel-angular-admin/node_modules/[email protected]/lib/binding.js:19:10)
at Object. (/yt/www/laravel-angular-admin/node_modules/[email protected]/lib/index.js:14:35)
at Module._compile (module.js:570:32)
Building the binary locally
Building: /usr/local/bin/node /yt/www/laravel-angular-admin/node_modules/[email protected]/bin/node-gyp.js rebuild –verbose –libsass_ext= –libsass_cflags= –libsass_ldflags= –libsass_library=
gyp info it worked if it ends with ok
gyp verb cli [ ‘/usr/local/bin/node’,
gyp verb cli ‘/yt/www/laravel-angular-admin/node_modules/[email protected]/bin/node-gyp.js’,
gyp verb cli ‘rebuild’,
gyp verb cli ‘–verbose’,
gyp verb cli ‘–libsass_ext=’,
gyp verb cli ‘–libsass_cflags=’,
gyp verb cli ‘–libsass_ldflags=’,
gyp verb cli ‘–libsass_library=’ ]
gyp info using [email protected]
gyp info using [email protected] | darwin | x64
gyp verb command rebuild []
gyp verb command clean []
gyp verb clean removing "build" directory
gyp verb command configure []
gyp verb check python checking for Python executable "python2" in the PATH
gyp verb which succeeded python2 /Applications/MAMP/Library/bin/python2
gyp verb check python version /Applications/MAMP/Library/bin/python2 -c "import platform; print(platform.python_version());" returned: "2.7.10\n"
gyp verb get node dir no –target version specified, falling back to host node version: 6.10.2
gyp verb command install [ ‘6.10.2’ ]
gyp verb install input version string "6.10.2"
gyp verb install installing version: 6.10.2
gyp verb install –ensure was passed, so won’t reinstall if already installed
gyp verb install version not already installed, continuing with install 6.10.2
gyp verb ensuring nodedir is created /Users/yt/.node-gyp/6.10.2
gyp verb created nodedir /Users/yt/.node-gyp/6.10.2
gyp http GET https://nodejs.org/download/release/v6.10.2/node-v6.10.2-headers.tar.gz
gyp WARN install got an error, rolling back install
gyp verb command remove [ ‘6.10.2’ ]
gyp verb remove using node-gyp dir: /Users/yt/.node-gyp
gyp verb remove removing target version: 6.10.2
gyp verb remove removing development files for version: 6.10.2
gyp ERR! configure error
gyp ERR! stack Error: read ECONNRESET
gyp ERR! stack at exports._errnoException (util.js:1018:11)
gyp ERR! stack at TLSWrap.onread (net.js:572:26)
gyp ERR! System Darwin 16.1.0
gyp ERR! command "/usr/local/bin/node" "/yt/www/laravel-angular-admin/node_modules/[email protected]/bin/node-gyp.js" "rebuild" "–verbose" "–libsass_ext=" "–libsass_cflags=" "–libsass_ldflags=" "–libsass_library="
gyp ERR! cwd /yt/www/laravel-angular-admin/node_modules/[email protected]
gyp ERR! node -v v6.10.2
gyp ERR! node-gyp -v v3.6.0
gyp ERR! not ok
Build failed with error code: 1

npm ERR! Darwin 16.1.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "rebuild" "node-sass"
npm ERR! node v6.10.2
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE
npm ERR! [email protected] postinstall: node scripts/build.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] postinstall script ‘node scripts/build.js’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the node-sass package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node scripts/build.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs node-sass
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls node-sass
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /yt/www/laravel-angular-admin/npm-debug.log


开心洋葱 , 版权所有丨如未注明 , 均为原创丨未经授权请勿修改 , 转载请注明Binary has a problem: Error: dlopen
喜欢 (0)
[开心洋葱]
分享 (0)
关于作者:
开心洋葱,开心洋葱头,水墨

您必须 登录 才能发表评论!

……